Outlook for Android Will Soon Require Android 8.0 or Newer – Thurrott.com

Microsoft’s Outlook app for Android is about to leave some users in the dust, as the email client will start requiring Android 8.0 or newer in May.

Source: Outlook for Android Will Soon Require Android 8.0 or Newer – Thurrott.com